Can not remove weight from workout (Read 418 times)

    I'm having trouble removing the weight in my workout entres. 

    When I edit my workout I remove the weight and save. But it still appears in the workouts table. 


    You can have a look at my last entries. The weight from 10/15 is correct, the ones from 10/17 and 10/19 are incorrect. ( This is another bug I think it automatically copies the weight from the last gps import but does not remember if it was in pounds or kg.


    Thanks! Smile


      I am not able to reproduce the weight problem.  I created a workout and specified the weight and then saved it.  I then edit the run and deleted the weight and then save it again.  The weight is no longer there.  What am I doing different?


      I checked the code for copying of the weights and it is specifying the weight unit so it should be correct.

        Hmm strange. I made a quick video cause 24 img/s is worth more than just a screenshot which is worth more than a thousand word.

        Maybe I'm doing something wrong Smile 




          Thanks for the video!  I was looking at the wrong place!  I found and fixed the problem.  It will be included in the next site update.


              This bug is reappearing for imported workouts (coming from garmin).

                Hi Coockie_jr,

                I cannot reproduce the problem.  I assume the repro steps are the same as in the video.  There was a problem earlier with the website caused by last night's update but that was fixed.  Could you see if that fixed your problem as well?


                eric Smile

                  Hi Eric,

                  Sorry I just realized that video was mentioning another problem (that is not longer there!)


                  My current bug is that activities coming from Garmin have the weight field filled in (from the last weight I entered I guess) even though "Fill new workouts with info from the last saved workout" is unchecked and no weight info is coming from Garmin.


                  I'll make some screenshots next time I import a workout if that not clear enough Smile


                    To stop RA from automatically filling in your body weight, try the following:


                    1.  Click on the little gear in upper right and select Options from drop down menu.

                    2.  Choose Log Preferences.

                    3.  Uncheck the option for filling in your weight from most recently entered weight.

                    4.  Save changes.


                    This is a log preference not a Garmin import preference.

                      Oh my bad! Thanks that helped!