1

GPS signal not acquiring 310xt (Read 47 times)

HoosierDaddy


    Until a week ago, my unit picked up the signal within a minute.

     

    Now it asks me if I am inside or if Ive moved 100 miles and just doesn't pick up the signal.  Even durin runs, says "Satellite signal lost".

     

    I dropped the watch about 3 feet to my tile floor recently - not sure that matters since it is supposed to be a pretty heavy duty watch.

     

    Have done a hard reset and it didn't fix.  Thoughts appreciated.


    day after day sameness

      It's busted.

      Choosing my words carefully has never been my strength I've been known to be vague and often pointless

      HoosierDaddy


        It's busted.

         

        this is a real response? why do you say this?


        day after day sameness

          To me it sounds like the antenna is busted and the signal isn't reaching the GPS receiver from the antenna. I'm inferring this from it asking if you're indoors when you're not  -- the indoors question being what the device does when it doesn't get a valid GPS signal at the GPS chipset.

          Choosing my words carefully has never been my strength I've been known to be vague and often pointless

          HoosierDaddy


            Okay - thanks.  Yeah, trying some trouble shooting but afraid something is physically wrong.  Everything else work incl. HR monitor.

            Supersono99


              Have you tried a hard reset?

               

              Nevermind, I see that you did. I've heard garmin has excellent customer service. I would try calling them.