12

Garmin Upload Issue (Read 144 times)

    I have multiple garmins and one of them is giving me problems with the upload.

     

    I can upload to garmin connect and another website that my coach requires (I believe it is just pulling from garmin connect).

     

    Have tried re-installing all the software and deleting TCX history, but still not able to upload to RA from one garmin 310 XT.

     

    Have tried through both chrome and IE.

     

    I did send a note from the upload function about this, but have yet to receive a response.

     

    Suggestions?

    And you can quote me as saying I was mis-quoted. Groucho Marx

     

    Rob

      Eric,

       

      Any suggestions?

      And you can quote me as saying I was mis-quoted. Groucho Marx

       

      Rob

        Hi Rob,

        This is a common problem with the 310XT.  You're on the right track when you uninstalled Ant Agent.  However, the uninstallation probably did not remove everything.  Please see this thread to see if that fixes the problem:

         

        https://www.runningahead.com/forums/topic/c6ffd004660047648d5791b42d4654a3

         

        eric Smile

          Hi Rob,

          This is a common problem with the 310XT.  You're on the right track when you uninstalled Ant Agent.  However, the uninstallation probably did not remove everything.  Please see this thread to see if that fixes the problem:

           

          https://www.runningahead.com/forums/topic/c6ffd004660047648d5791b42d4654a3

           

          eric Smile

           

          I will give it a shot.

           

          Silly question -- why would uploads work for one of the 310s and not the other?  Additional silly question -- why would this be a problem on multiple computers?

          And you can quote me as saying I was mis-quoted. Groucho Marx

           

          Rob


          HobbyJogger & HobbyRacer

            If one watch has bad data, the problem would be correlated with just that watch, and not the other, and would follow it around on all

            computers.

             

            garmin support has seemed to suggest that sometimes the 310xt winds up with bad data in a workout.

             

            I've seen it suggested that deleting old data from the 310xt helps to reduce the chance of it getting into a bad data state. (Not that that is helpful to you whilst you're struggling with the problem, but perhaps it will be helpful later.)

            It's a 5k. It hurt like hell...then I tried to pick it up. The end.

              I'm having an upload issue with my trusty 305. It crashes on import using Safari, Firefox, and Chrome. Yup, tried them all. I've tried updating Connect on my computer and resetting my Garmin, too. At first, it would seem to be uploading okay but end with a "there is an error communicating with your device" message. Now it kills the RA page altogether. Frozen dead. Got a sec to help, eric? XO

                Hi Rachel,

                The problem is most likely with the USB port.  Try plugging the GPS to a different USB port, preferably one directly to the back of the computer.  If none of the ports fixes the problem, try a different USB cable.

                 

                eric Smile

                  Thanks eric! I'll try it tomorrow and report back.

                    Hm, eric. I tried a different cable and it didn't help. Sad

                     

                    What happened (and often happens) is that (in Chrome Version 34.0.1847.131) I went to the training log and upload GPS data and the spinny beach ball of doom did its thing until I was asked to kill the page. Sometimes that happens, sometimes I get an "error communicating with your device" dealy. I get the beep and everything from the Garmin if I get past the spinny freeze point, so I know it's connected. Today, I went over to Safari and the upload worked fine. Sometimes it doesn't. Ideas? Am I looking at a bad cradle or the possibility that my 7-year-old Garmin is failing? It seems more like a website communication issue to me.

                     

                    Thanks for looking into it!

                      Rachel, I'm having the same type problem with my new computer. Sometimes turning the Garmin on and/or off helps, taking the Garmin off the cradle or unplugging also sometimes works. Nothing is consistent though, including which browser will work and which won't. Frustrating.

                        Hi Rachel,

                        Have you tried using a different USB port?  The problem you're experiencing is specific to the 305.  The other problematic model is the 310XT, but that is caused by the Ant Agent.  If you've already tried all the USB ports, then try resetting the GPS by holding the Mode and Reset buttons for a few seconds.  If you manage to upload all your workouts, consider deleting all the workouts from the GPS.  It'll upload faster because there are fewer workouts to search for, and tends to alleviate your problem.

                         

                        eric Smile

                        bobinpittsburgh


                          Hi Rachel,

                          Have you tried using a different USB port?  The problem you're experiencing is specific to the 305.  The other problematic model is the 310XT, but that is caused by the Ant Agent.  If you've already tried all the USB ports, then try resetting the GPS by holding the Mode and Reset buttons for a few seconds.  If you manage to upload all your workouts, consider deleting all the workouts from the GPS.  It'll upload faster because there are fewer workouts to search for, and tends to alleviate your problem.

                           

                          eric Smile

                           

                          I can attest to that.  I haven't been able to get my 310xt to upload workouts since the beginning of February. 

                          MrH


                            My 310XT uploads data to the PC and to Garmin Connect, but RA (having recognized it in the past) doesn't think there's a connected device.

                             

                            Any ideas?

                            The process is the goal.

                            Men heap together the mistakes of their lives, and create a monster they call Destiny.


                            HobbyJogger & HobbyRacer

                              My 310XT uploads data to the PC and to Garmin Connect, but RA (having recognized it in the past) doesn't think there's a connected device.

                               

                              Any ideas?

                               

                              I've solved this a number of times with a combination of hard watch reset plus deleting the watch device directory on the computer. This has occurred for me more than several times. As far as I can tell, when it occurs, the problem is correlated with the watch -- not with the computer. That is, I can see the same issue with the same watch against other computers.

                               

                              garmin support has said it is a bad workout on the watch.

                               

                              (garmin support has also sent me a new "GarminDevice.XML" file to replace the one in the watch device directory, but that never fixed the issue.)

                               

                              The problem with hard reset is that it may lose all the data on your watch; garmin support seems to not know why sometimes it does and sometimes it doesn't.

                               

                              I've seen it suggested to delete all the watch history frequently, to cut down the incidence of the watch recording bad workouts.

                               

                              Note: When it has happened, I can see that the 310xt is missing from Ant Agent's Device Settings dropdown list, so I called garmin connect with that as the issue (not RA) -- that the watch vanished from the Device Settings menu.

                               

                              Note2: If you have multiple watches, you have to figure out which watch device directory is which, on the computer.

                              It's a 5k. It hurt like hell...then I tried to pick it up. The end.

                              MrH


                                I'm not understanding the process here. When I move the 310XT near the PC data transfer occurs to the PC and uploads the workouts to Garmin Connect. So the 310XT ---> Ant Stick ---->PC connection seems to be working OK. What is not happening is RA seeing the data that has been transferred to the PC.

                                 

                                Does RA need to interact directly with the watch, or does it pull data from a directory on the PC?

                                The process is the goal.

                                Men heap together the mistakes of their lives, and create a monster they call Destiny.

                                12