12

Mileage bug?? (Read 332 times)


On the road back

    Eric - this was strange and I thought given the recent craziness that I'd at least provide you with 2 screenshots of an inconsistency with my mileage totals.  I only noticed it after I'd uploaded today's run, but it looks like it may be connected to the last 2 runs (because that seems to equal the difference in the totals).

     

    The goal widget on my summary page has me at 423 (which is right) but my yearly total is 413.  I'm also at 413 in the group list that I provided.  I didn't check other groups.

     

    At any rate, I know how much I've run, so this is low on my radar and shouldn't cause you any lack of sleep.  I just wanted to pass it on to you.  Thanks!

     

     

    2013 Goals: Run more. Smile while I do it. Complete 2 marathons in a year. (1 down, 1 to go)

      Now that I checked, my yearly mileage also shows different totals in the overall run total and the goal widgets. It's a 3 mile difference and not really important, but wanted to let you know.

      2014 goals

      1800 miles; 5k < 25:00; 10k < 53:00HM < 2:00

       

      Upcoming:

      NYC Half Marathon 3/16Boston Marathon 4/21; Newport Liberty HM 9/2; Trenton Half Marathon 10/8

        There is indeed a mileage bug.  It has been particularly hard to track down.  I thought I finally fixed it at the end of last year but apparently not.  The yearly mileage is cached so that it can be displayed quickly without having to go through all the records and sum them up.  Under a certain circumstance, the yearly mileage isn't updated.  Because it happens so rarely, I haven't been able to find it.  For now, I'll just reset the yearly distance.  If you can keep an eye out for it, it would be much appreciated.

          Any chance this has something to do with a run or runs marked as "Private entry" in your log? A couple of years back, my YTD widget did not match the Pace bunny's total and I traced it to the Pace bunny "seeing" the mileage from one private entry which the YTD widget did not show. I made that run public and then the two mileage totals matched.

          Failure is a good place to start.

          half-fast


            Hi Eric - Was the yearly mileage reset for all or just the OP?  Mine still has the issue.

             

            @jpdeaux - I don't have any marked (that I know of) as "Private Entry".

              There is indeed a mileage bug.  It has been particularly hard to track down.  I thought I finally fixed it at the end of last year but apparently not.  The yearly mileage is cached so that it can be displayed quickly without having to go through all the records and sum them up.  Under a certain circumstance, the yearly mileage isn't updated.  Because it happens so rarely, I haven't been able to find it.  For now, I'll just reset the yearly distance.  If you can keep an eye out for it, it would be much appreciated.

               

              It's back. I just noticed yesterday that the overall run total and the progress towards goal total were different by about 14 miles. I am pretty sure it was okay a week ago. It's not a big deal for me, but I'm letting you know if this helps you find the bug.

              2014 goals

              1800 miles; 5k < 25:00; 10k < 53:00HM < 2:00

               

              Upcoming:

              NYC Half Marathon 3/16Boston Marathon 4/21; Newport Liberty HM 9/2; Trenton Half Marathon 10/8

                It would help me a great deal if you can tell me all the ways you entered your info.  For example, do you enter them manually via the web site, or upload them via GPS and save them all at once or individually, or do you use the Android app, or combinations of these methods?

                  I upload them from my Garmin. I usually upload each one at a time. Sometimes I might have more completed more than one workout in a day (a bike ride followed by a run or a warm-up jog before a race followed by a jog home) and then I upload two or three workouts at a time.

                  2014 goals

                  1800 miles; 5k < 25:00; 10k < 53:00HM < 2:00

                   

                  Upcoming:

                  NYC Half Marathon 3/16Boston Marathon 4/21; Newport Liberty HM 9/2; Trenton Half Marathon 10/8

                    After you uploaded multiple workouts, do you save each workout by clicking on the diskette icon, or do you click Save All and then edit them?

                      I edit and save each one individually. I do not click on Save All.

                      2014 goals

                      1800 miles; 5k < 25:00; 10k < 53:00HM < 2:00

                       

                      Upcoming:

                      NYC Half Marathon 3/16Boston Marathon 4/21; Newport Liberty HM 9/2; Trenton Half Marathon 10/8

                      half-fast


                        Hi Eric - I have a similar issue.  All of my data was entered manually via the website.

                          I thought the bug was caused by bike entries, but theyapper66 doesn't have any bike entries.  I am still not able to reproduce the problem.  It only seems to happy to a handful of users so the problem is very obscure.

                           

                          half-fast: could you provide more info on your problem?  Your numbers seem to be correct so I might be looking at the wrong place.

                          half-fast


                            Hi Eric - It looks like the mileage is correct, but the pace is off.  I think I have found the source of my issue, but not sure why it's the issue.  March 2013 has a pace of 4:53...no where close to reality for me Smile  I had several runs that month that had mileage, but not times.

                             

                            I expect that is what is causing the pace to be off, but I thought those runs would not be used in the overall pace calculation....

                              Hi Eric - It looks like the mileage is correct, but the pace is off.  I think I have found the source of my issue, but not sure why it's the issue.  March 2013 has a pace of 4:53...no where close to reality for me Smile  I had several runs that month that had mileage, but not times.

                               

                              I expect that is what is causing the pace to be off, but I thought those runs would not be used in the overall pace calculation....

                               

                              You are referring to the yearly pace.  The yearly data is cached to improve overall site performance.  Instead of locating all your workouts for the year and then summing them up, the year's distance and duration are stored as two numbers.  When you want to see the year's numbers, they are displayed.  Pace is calculated by dividing distance by duration.  If you have several workouts without duration, then the pace will be off.  The only way to fix it is to store another set of distance and duration values for workouts that contain both.  I'll consider that when I revamp the log.

                              half-fast


                                Hi Eric -

                                 

                                If when I run a monthly report (from the left-side menu) it pulls from the yearly cached data and the Monthly mileage widget on the summary page uses "live" data then, yes that would explain why I'm seeing a discrepancy.

                                 

                                Thanks again for the help!

                                12