1

Doesn't detect Garmin (Read 797 times)

    This is because I don't think you have enough work to do eric *grin*

    When I try to upload from my Garmin (405), it regularly states it can't detect it:

    Device: Not connected

    GPS import currently supports the Garmin Forerunner GPS only and requires the Garmin Communicator Plugin.

    You need to install the Garmin Communicator Plugin before you can use your Forerunner with RunningAHEAD.

    Wait...

    Status: Unable to communicate with plugin

    If I refresh the page, it appears to find it. I clicked upload, it has uploaded a workout (I think there was only 1 to upload), but then told me it couldn't find the device again. Not a massive issue or a priority as it does appear to work with a refresh or 2. But so you know Smile

    Never forget the man who mistook his wife for a hat!

    Ποτέ δεν ξεχνά τον άνθρωπο που μπέρδεψε τη γυναίκα του για ένα καπέλο!


    an amazing likeness

      "Unable to communicate with plugin"

       

      This is the key.  That means that the underlying Garmin plugin, for whatever reason, isn't responding to RA.  As you probably know, RA doesn't actually suck the data from the ForeRunner, the Garmin plugin does.


      If this is a Windows-based PC, then two things to try to help:

       

      (1) go to the device manager and delete the Garmin device, then re-add it

       

      (2) use another USB port for the Ant stick thingie

      Choosing my words carefully has never been my strength I've been known to be vague and often pointless

        "Unable to communicate with plugin"

         

        This is the key.  That means that the underlying Garmin plugin, for whatever reason, isn't responding to RA.  As you probably know, RA doesn't actually suck the data from the ForeRunner, the Garmin plugin does.


        If this is a Windows-based PC, then two things to try to help:

         

        (1) go to the device manager and delete the Garmin device, then re-add it

         

        (2) use another USB port for the Ant stick thingie

         

        The point I was trying to make is that refreshing the page makes it work. Suggesting it's not a problem related to my computer or device. The device functions perfectly outside of RA (e.g. G Connect)

        Never forget the man who mistook his wife for a hat!

        Ποτέ δεν ξεχνά τον άνθρωπο που μπέρδεψε τη γυναίκα του για ένα καπέλο!


        an amazing likeness

          I understand what you were describing, I see it myself.  The page refresh is working because the Garmin plug-in starts working after the refresh.

          Choosing my words carefully has never been my strength I've been known to be vague and often pointless

            I don't understand why there's a discrepancy between RA and Garmin Connect since both use the same software.  It is frustrating that people have fewer problems with GC.  Oftentimes, I wonder if the plugin intentionally misbehaves.  I've already found one instance where the plugin works only with GC and no other sites.