1

tbody tags get inserted automatically then show on the page (Read 472 times)


HobbyJogger & HobbyRacer

    I think that the server is synthesizing & inserting tbody opening and closing tags, but then the renderer is html-encoding them, so they show on the page. Example: home page of 2000mi group right now. (I tried removing them using the html edit, but they reappeared.)

    It's a 5k. It hurt like hell...then I tried to pick it up. The end.

      I think tbody is required element in the table tag but most people don't use it and the browsers are nice enough to put it in automatically.  I didn't know about this until a couple of years ago but it was after I create the groups.  All the html code on the site are filtered and only certain tags are allowed.  The disallowed tags are rendered as text, which is what you're seeing.  I added tbody to the allow tags and the problem should be fixed.


      HobbyJogger & HobbyRacer

        Looks fixed. Thanks.

         

        <piling-on> Along the same lines, I think it would make sense to allow thead, tfoot, and th.  </piling-on>

         

         

        (MTA: added pretend tags)

        It's a 5k. It hurt like hell...then I tried to pick it up. The end.

          Now you're just piling on Tongue

            Thanks for the fix eric.  Had this issue with the Chicago Marathon group page, but didn't want to take up your time.  Glad someone else saw this too.

             

            ETA: Any chance you could add <strong> and <em> to the permitted list?

            How To Run a Marathon: Step 1 - start running. There is no Step 2.