1

Site unable to load workouts in TCX compressed ZIP format (Read 23 times)

josevnz


    Hello Team,

     

    I tried to upload my workouts on the TCX format (each file is compressed using ZIP) and the site allows me to upload the workout but they never show up when I click on the 'Imported Workouts' button.

     

    Has anyone else experience this issue? The uncompressed TCX files look well (properly formed XML) and I can uncompressed the files (just to make sure the .zip file is not corrupted).

     

    Total size for the upload is 15M.

     

    I had no issues uploading several workouts at the same time in the GPX format.

     

    Should I convert the TCX workouts to GPX?

     

    Thanks in advance,

     

    --Jose

    josevnz


      Update: I decided to convert the TCX files to GPX using the following tool: http://jwhgt.worldwidehome.de/

       

      Then used it like this (also compressed the resulting files to .zip format. I'm running this on a Linux terminal):

       

      for file in $(ls *.tcx); do

        new_file=$(echo $file| sed 's#.tcx#.gpx#g');

        java -jar JWHGT/JWHGT.jar -con -exsd hrec -ifhf tcx -ifhrm "$file" -off gpx -of "$new_file";

        zip "$new_file".zip "$new_file"

      done

       

      The upload works but the site fails silently again importing the files on the new format.


      an amazing likeness

        Interesting. I don't have a specific solution for you -- but as information to help you find the problem:

         

        1. I was able to upload a single TCX file in native format, that is, uncompressed. No errors. The RunningAhead importer processed the file.

         

        2. I was able to upload a ZIP of multiple TCX files and the RunningAhead importer extracted the files and they were available for import as individual workouts.

         

        In my #2 test -- I used 3 files, so I didn't test at the scale it seems you're may be working.

        Acceptable at a dance, invaluable in a shipwreck.

        josevnz


          Something is off. I tried a single uncompressed file, didn't work. Also put all the TCX files inside a zip and no luck either. Without a log on the server I cannot tell why the importer doesn't like the files.

           

          Anyways, thanks for the help.

           

          --Jose


          an amazing likeness

            Reads to me that your TCX files aren't valid for some reason...but that's speculation on my part.

             

            Just to confirm...the 'click path' I used was:

             

            Main page (...runningahead.com/forums) > click on inbox icon in main title bar, 3rd icon on right (...runningahead.com/logs/{guid}/tools/import)  > browse > [select file from file system] > upload > data importer then generates dialog:

             

            Your data has been transferred to the server and is being processed. It will take a couple of minutes before your data becomes available. You can leave this page to browse your log or the forums as you wait. A message bar will appear at the top of the page when the data is ready.

             

            > uploaded file count appears in import inbox in main title bar > click import inbox (or  training log > tools > upload from file (tab) ) > click save (disk) icon on imported workout.

            Acceptable at a dance, invaluable in a shipwreck.