1

Access to Individual Logs from Group Reports and 404 Error (Read 55 times)

HermosaBoy


    Whenever I try to access a User Log from a User Group Report page, I receive the following error message:

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

     

    This occurs even when attempting to access my own log.

     

    I am still able to access friend's user logs from the Browse User Logs function.

    And you can quote me as saying I was mis-quoted. Groucho Marx

     

    Rob

    LedLincoln


    not bad for mile 25

      Ha - good catch! I just tried it, and I even get a 404 for my own log.


      an amazing likeness

        Yep, definitely a bug in that the UI is passing in the wrong log id when you come in from a Group list. For example, using my log:

         

        The url from anything other than Group is:

         

        https://www.runningahead.com/logs/xxxxxxxx

         

        But from a group report link, it tries to open:

         

        https://www.runningahead.com/logs/yyyyyyy

         

        The url from the group link is not valid, so it generates the 404 error.

         

        (for clarity, I substituted the xxxx and yyyy stuff to save folks looking at long strings of the GUID)

        Acceptable at a dance, invaluable in a shipwreck.

        eric :)


          Hi HermosaBoy,

          Nice find! This bug has been around for a little while. I'm overhauling the backend code and some of the changes that are not compatible with the front end was introduced. I just applied the fix.

           

          eric Smile

          HermosaBoy


            Thanks Eric!

            And you can quote me as saying I was mis-quoted. Groucho Marx

             

            Rob