Upload from GPS hangs with "Searching for connected GPS device(s)" (Read 802 times)

    After having uploaded successfully forever (for over a year) this morning I seem to have a problem. The Upload from GPS hangs with the message "Searching for connected GPS device(s)". This is on Windows 7 using Firefox 7.01 using ANT Agent 2.2.17. I was able to upload the data to GaminConnect without any issues. So, I thought i would try to upload from file using the TCX file that Garmin had imported. But when I try Upload from File, select tcx file type and browse to the file, the Upload button never lights up so I can't upload the TCX data file. So it seems I can't get the data either way.


      I don't know about ANT but I have found sometimes there is a problem with my connection, it won't work in Firefox but works in IE.  No rhyme or reason so if it doesn't work I try IE.  I had the same issue with the upload to the Garmin application working but not the browser upload.

      Bill Wagnon / stl

        Thanks, but no luck there either. I'll try again tonight from home from XP within a VirtualBox partition within Linux.
          Thanks, but no luck there either. I'll try again tonight from home from XP within a VirtualBox partition within Linux.


          IME this doesn't work so well (although it's a while since I tried). The transfer speed is so low that things keep timing out. Something to do with the way Virtualbox handles making USB available to the virtual machine I suppose.

            Actually, it did work from XP within VirtualBox. It did take much longer than it usually does, though. I was about to give up on it. The run was only 10k on a treadmill which usually goes through fairly quickly, but this time it took a lot longer. No idea why. It always does take much longer when uploading through VirtualBox than directly into Windows, but the only time I could not get the data uploaded was when the data file was for a marathon. I have never had a case before yesterday when a file would upload into GarminConnect but not upload into RunningAhead, and this was when uploading directly into Windows. Yesterday was a first. When I run in the morning before work or at lunchtime from work I usually upload my data directly into Windows 7 at the office. I won't have occasion to do that again until next week, so I'll have to wait to see if this was just a one time problem. We have had some new security stuff installed, so there is always the possibility that it is somehow being blocked. But I was able to upload into GarminConnect, so I don't know. I also don't understand why I couldn't get the upload button to light up so that I could import the tcx file after I had uploaded it to GarminConnect. (I still dream of the day when I'll be able to upload directly into Linux with ANT Agent. Sigh....)

              I'm somewhat irked by the fact that upload works fine for Garmin Connect but not RA.  I am using the software provided by Garmin and so is GC so there is no reason why there should be a discrepancy.  However, there is and I found one instance where the software used to work only if the url pointed to garmin.com.


              I don't know if this is another one of those problems.  The presence of the ANT agent makes the problem that much more complicated since my understanding is that the Garmin Communicator talks to the ANT agent and not the GPS.


              Other users reported similar problems and I am not able to reproduce and thus fix it.  If you would like to investigate it, it would be much appreciated.

                I thought I had this worked out, but now I'm confused again. With Garmin's latest ANT Agent release, 2.2.17 (or possibly the 3.90 310xt firmware upgrade?) a problem was introduced in that the device will continue retransmitting the data, time after time until the device is turned off.  There are complaints about this in the Garmin 310xt forums.


                I usually have GaminConnect (GC) up in one browser tab and RunningAhead (RA) in another tab.  The ANT agent grabs the data and it goes into GC first.  I then attempt to upload into RA.  This has worked fine until a couple of weeks ago when the above mentioned upgrades occurred.  My thinking was that GC (or ANT) was continuing to hold a lock on the device and so RA would just keep waiting for that lock to be cleared, seeming to hang.  The last time this occurred at home I closed the GC tab and lo and behold, RA then grabbed the data and all was well.


                However, the last couple of days, I did NOT close the GC tab and suddenly all is well with RA being able to do the upload right after the upload into GC.  It is working right both in my Linux/VirtualBox/XP setup as well as my work Windows 7 setup.


                So, since I haven't had it fail again, I guess it back to the drawing board to find out what the issue is.  I still think it is somehow related to this retransmitting business though.

                  Thank you for substantiating my believe that the problem is entirely caused by Garmin's software.  It seems to happen more often with ANT agent devices than GPSes that don't use the ANT agent.  Maybe the solution is to create my own agent...

                    Especially if you write it for Linux. Wink