1

Problem with Custom Workout Types (Read 1119 times)

    1. Tried entrering a new run, using a custom run type "Low HR". However, it shows up as "<no>" and I can't get it to change. 2. Also, the custom run options page (Options|My Log Preferences) is messed up. You can't add new custom run types or change existing ones.</no>
    How To Run a Marathon: Step 1 - start running. There is no Step 2.
      Hi mkleiman,
      1. Tried entrering a new run, using a custom run type "Low HR". However, it shows up as "<no>" and I can't get it to change.</no>
      I changed the code a little, so it won't say "<no>" anymore. The cause of your problem is that you had a run with a custom type, let's say fartlek, and then you removed fartlek from your custom type. Now you have a run without a type name. You can edit this run, and change it's type to something else and your problem should be fixed.
      2. Also, the custom run options page (Options|My Log Preferences) is messed up. You can't add new custom run types or change existing ones.
      To add/change custom run types, click on the "Running" link, and it will bring you to another page called "Workout Preferences." You can then change your run types there. Hope this helps. Let me know if it still doesn't work for you. eric Smile </no>
        I changed the code a little, so it won't say "<no>" anymore. The cause of your problem is that you had a run with a custom type, let's say fartlek, and then you removed fartlek from your custom type. Now you have a run without a type name. You can edit this run, and change it's type to something else and your problem should be fixed. To add/change custom run types, click on the "Running" link, and it will bring you to another page called "Workout Preferences." You can then change your run types there. Hope this helps. Let me know if it still doesn't work for you. </no>
        I'm afraid there's something more serious going on. 1. I never deleted any run types. I've only had one custom run type ("Low HR") and I haven't deleted it either before or after the upgrade. In fact, it still appears in the list of custom run types. However, I cannot change the new "Run_0011" to "Low HR" (I can change it to one of the stock run types, but not to "Low HR"). "Low HR" appears in the drop-down in the "Edit Run Entry" screen, but it will not save the change. 2. The custom run types page is still broken for me. For example, I tried to create a new custom run type called "Fake". It did not save the change. Firefox 1.0.7 if it matters. Edit: Same problems with MS IE.
        How To Run a Marathon: Step 1 - start running. There is no Step 2.
          Hrm... this sounds bad. I'll try to replicate your problem and see if I can fix it today. eric Smile
            I found and fixed the problems. You should be able to change the run type now, as well as modify your custom types. Let me know if you encounter futher problems. eric Smile
              I found and fixed the problems.
              Yes you did. Smile All appears to be working as intended. Many thanks eric for your effort and commitment.
              How To Run a Marathon: Step 1 - start running. There is no Step 2.