Windows Unable to see Device Problem/Solution (Read 136 times)

    I dropped out of running a few years back and have decided to get back. When I last used my Garmin Forerunner 305 I was using Vista and had no problems at all. I charged up my Garmin and it is working fine. I can sync to OSX however syncing to Windows 7 was not working. If I plugged the device in and as soon as Windows loaded it tried to sync it would recognize the Garmin but before it could finish the upload it would error out and when I tried upload again it could not find the device. Being that I work in IT I decided to look into this because I see the problem a lot on the internet and have not seen a lot of solutions. This problem happens not only on RunningAHEAD but also Training Center and Garmin connect.


    The problem seems to be with the USB drivers conflicting with something else on the system. Shortly after Windows 7 loaded the USB drivers for the Garmin the program would come around and kill the driver. The problem ended up being with two services that load at startup (mccicmservice and
    mcciservicehost). When I disable these services it works fine. When I researched this I discovered these services were installed automatically when I configured internet service from ATT U-Verse. Version also uses this software with their FIOS service. If I go into "Control Panel/Programs/Uninstall a Program" I found a program called "ATT Self Support Tool". Uninstall this program and your Garmin will function again.


    The ATT Self Support Tool is used by the ATT Staff if you call in a problem. You do not need to to connect to the internet and under normal circumstances. Uninstalling it will harm nothing.


    I am posting this not as a current problem but in hopes that if someone has this issue they do not have to spend the time I did discovering the solution.