Creating new shoe equipment (Read 38 times)




    Anybody else than me having issues when creating a new equipment?


    I've just bought a new pair of Xero hiking boots and running shoes. When I create them as new equipment everything is fine but they don't appear in the drop-down for the activity (Walk) itself. When I go back to check the new shoe equipment it has been changed from 'Walk' to 'Bike' in the Activity field?? When I change it back to 'Walk' some of the info disappears (I can type it in again) but the field for shoe size also disappears? After doing this I can use the equipment for the activity. So it kinda works - but not the way I think it should work :-)





      I've tried for other things like Run but the problem only occurs on Walk equipment. I've also tried different browser, Edge and Firefox, but the result is the same.
      I found this old tread RunningAHEAD - Topic: Equipment labeled as Run changes to Bike when editing and it seems to be the same problem just for Walk instead of Run.


      Kind Regards,


      an amazing likeness

        Tried to few times to re-create your report and can't quite get the same issue to happen in my testing.  Here's my steps for you to review and tell me where I'm going astray:



        New Equipment

        Activity = Walk

        Manufacturer = Other (because once I select Activity=Walk, no manufacturers are in pick list)

        Model = "Xero hiking"

        Name = "Shoes 1"

        Purchase date = [today]



        Check equipment list and new equipment entered is there. Good.  Now enter a walk workout to see if the equipment can be selected:


        New Walk Entry

        Activity = Walk

        Equipment = "Xero Hiking (Shoes 1)" is in pick list


        As to your note on "Bike" -- this happens when you choose to Edit an equipment since "Bike" is the first entry in the activity pick list. I do agree that it is a bug or anomaly that the system changes the Activity field just because you choose to edit the equipment.

        Acceptable at a dance, invaluable in a shipwreck.


          Hi Milktruck,

          Thanks for your reply and you are absolutely correct. I don't see at a big issue either and it wasn't my intend to cause any alarm about it 


          So to sum it up I see 2 minor bugs dealing with equipment for Walk:

          1) When editing a Walk equipment it get changed into Bike and some data is erased and cannot be re-entered. Ex. Size where the field for this vanish when changing the Bike back to Walk

          2) When choosing manufacture 'Other' is the only one on the list of values