1234

Updated Facebook App (Read 1947 times)

    Try this:

    1. go to the preferences tab

    2. click the "Unlink my RunningAHEAD and Facebook accounts." link at the bottom of the page

    3. click the Unlink button

    4. you now should be redirected back to the register page

    5. go to Account (upper right corner) and select "Account Settings"

    6. click Applications on the left

    7. click the x to the right of RunningAHEAD Training Log to uninstall the app

    8. go to http://apps.facebook.com/runningahead/ to reinstall it

    9. try to give it the publish permission again and see if it makes a difference.

     

    Same thing.  I get the permissions box, check the Publish All My Activities button, and save.  New tab opens without closing or visibly saving the permissions.  When I go to preferences, the permission is no longer checked.

     

     

    "I aim to misbehave."

      I've tried unlinking, relinking, publishing and saving ... entered workout ... didn't post.  Let me know if I can try something else!

       

      Knifey,

      Could you try this: http://www.runningahead.com/forums/post/93403824f2ba44abadd6a0acfa8476e6#focus

        Knifey,

        Could you try this: http://www.runningahead.com/forums/post/93403824f2ba44abadd6a0acfa8476e6#focus

         No go...it does everything it is supposed to do in terms of the redirecting pop up...publish, etc...but then doesn't post to my FB wall.  It does show on the actual app...so my workout that is copying is there 4 times!  Just not on my wall.

          Try this:

          1. go to the preferences tab

          2. click the "Unlink my RunningAHEAD and Facebook accounts." link at the bottom of the page

          3. click the Unlink button

          4. you now should be redirected back to the register page

          5. go to Account (upper right corner) and select "Account Settings"

          6. click Applications on the left

          7. click the x to the right of RunningAHEAD Training Log to uninstall the app

          8. go to http://apps.facebook.com/runningahead/ to reinstall it

          9. try to give it the publish permission again and see if it makes a difference.

           

          I tried all this and got the same results...

          And you can quote me as saying I was mis-quoted. Groucho Marx

           

          Rob

            I think I finally reproduced the problem.  As a double check, when you are in the app, does the url begin with "http://" or "https://"?  The second one has an 's at the end.

              https://

               

              Do we need to turn off secure browsing to get it hooked up?

               

               

              "I aim to misbehave."

                I think I finally reproduced the problem.  As a double check, when you are in the app, does the url begin with "http://" or "https://"?  The second one has an 's at the end.

                 

                https://apps.facebook.com/runningahead/?ref=bookmarks&fb_source=bookmarks_apps&fb_bmpos=1_

                And you can quote me as saying I was mis-quoted. Groucho Marx

                 

                Rob

                  It looks like the app is not properly handling https traffic.  I am looking into it.  You can disable https if you want to use the app now, or you can wait for the fix.  If I can set up my development machine to properly handle https traffic, then I can probably fix the problem quickly.  The trouble is getting an ssl certificate that FB will accept.

                    I disbles secure browsing in FB, went therought he publish process (worked as expected) then turned secure browsing back on.  I just did a test entry and it posted to my wall.

                     

                    Looks like you only need secure browsing off to set the permissions, then you can turn it back on.

                     

                     

                    "I aim to misbehave."

                      Thanks for confirming my hypothesis.

                        I tried the steps to include disabling secure browsing.

                         

                        When I reinstall RA, it starts to show summary information for me and friends, then that disappears.

                         

                        I try to enable publish and all I have available on the right is Publish and Save.

                         

                        I select Publish and I get a request for permission.  I select allow and then make my publish selections.  It appears to work, but again does the show then hide of the summary for friends and me.

                         

                        Will now try posting a workout.

                         

                        ETA -- Seems to have posted correctly.  However, I still cannot see the summary information for my friends and me on the app page.

                        And you can quote me as saying I was mis-quoted. Groucho Marx

                         

                        Rob

                        rundwoods


                          I tried the steps to include disabling secure browsing.

                           

                          When I reinstall RA, it starts to show summary information for me and friends, then that disappears.

                           

                          I try to enable publish and all I have available on the right is Publish and Save.

                           

                          I select Publish and I get a request for permission.  I select allow and then make my publish selections.  It appears to work, but again does the show then hide of the summary for friends and me.

                           

                          Will now try posting a workout.

                           

                          ETA -- Seems to have posted correctly.  However, I still cannot see the summary information for my friends and me on the app page.

                           

                           

                          Same thing happening for me right now.


                          Lush Extraordinaire

                            I tried to reset permissions and it kept redirecting to summary when I hit preferences. So I decided to delete and try to reinstall. Oops. Now the app just keeps redirecting from facebook to RA over and over.

                             

                            I only did a piddly 1 mile run in the dark tonight so I'm cool with not posting for the day. ;-) lol

                            5k - 23:30

                            10k - 49:00

                            Half - 1:48:34

                            Full - 4:01:28

                             

                            Shut the eff up and run.

                              I think I finally found and fixed the publish button problem.  It turned out to be not related to your secure browsing preferences.  I don't know why it made a difference.  Many other app developers have experienced this problem.  Either FB's documentation is completely useless, or their code is extra buggy.  I did everything according to their documentation and it was still not working.  To add insult to injury, their documentation, flow chart and sample code on the same page do not match each other.  The fix involved adding an extra *undocumented* parameter.  I do not like the fix one bit but at the same time, I spent 36 hours on tracking down this bug.

                               

                              As for the summary page hiding information, this is another FB bug that they introduced sometime yesterday.  It's another exercise of digging through their documentation followed by hours of Googling to find threads about how everyone else is having the same issue.  I can't wait until the FB fad is over.


                              Patzer

                                Thanks SO MUCH!  It's now working for me.

                                Current goal: an Olympic distance triathlon. Did two of them! New goal: a half-ironman?? Did that too. New goal: I'll have to get back to you.
                                1234