1

Garmin USB Drivers and Windows 7 (Read 1651 times)

stenine


    This isn't really a RunningAhead issue, but I hope that posting here might find someone else who has run into the same problem.

     

    I've got a Windows 7 64-bit machine.  When I connect my garmin 305, I can't get it to be recognized either by Garming Training Center, or on the Garmin Communicator plugin page.  I've been through several cycles of updating all the drivers, and garming software, but it still doesn't find the device.

     

    I've done quite a bit of searching on the web for solutions, but I don't see any definitive answer on what action to take.

     

    Has anyone had this issue and what did you do to solve it?

      Double check that your Garmin is paired with your USB.  I had paired mine a long time ago, then discovered that within the watch itself there was a setting that was now disabled.  When I enabled it, from memory I suddenly had a new icon in my task bar and setup continued. 


      the man put the gun away

        plug it into one of the usb ports in the back of the machine.  I spent two days and countless chat sessions only to find that the front ports are sometimes not adequate enough to sense your device. 

         

        I have since retried with success to plug back into the front.  Not sure if that was due to a reboot, or the fact that the computer started recognizing it again following thebackside plugin.

          I am using a 64 bit Windows 7 machine and have no problems.  When the GPS is in the cradle, do you see the "charging" prompt on the GPS?  I'm guessing that you don't.  Try cleaning the contacts and the pins, and moving to a different USB port and see if that makes a difference.

          stenine


            Thanks.  I'll give all this a try.