1

Garmin 305 + Mac 10.3.9? (Read 508 times)

    I should have entitle this thread "Computer illiterate old-head needs help. Please show mercy." So....tryin' to install my 305 disc, I'm noticing the system requirements spec. a 10.4 or later...can I just try installing it and hope it doesn't notice (hee hee hee)? Right now, I've clicked on the "install" icon, but ain't nuthin' happenin.' Tips? thank you. SWALOT, aka Cap't EBKAC held the door for everyone in computer class

     I like running alone.


    A Dance with Monkeys

      I'd upgrade to 10.5.x. Just sayin. Big grin