1

RA Update (May 22) (Read 2019 times)

    Hi everyone,

    I uploaded the latest changes to RA this afternoon.  As some of you have discovered, the two major changes are private messaging and a rich text editor.

     

    As I told the beta users, the message center is my first pass at creating a function that lets you communicate privately with other users since RA keeps all email addresses secret to reduce spam.  I recognize that it is lacking in features but I had to start somewhere.

     

    As I worked on private messaging, I realized that it needed a better text editor.  While most forum users are used to the crude editor, private messaging needed an easier editor.  So, I switched over to the current editor.  Some of you are having trouble with the new editor and I'm doing my best to reproduce the problem but so far I haven't  had any luck.  If you would like to helpe me figure this out, could you provide as much info as you can, even down to the exact sequence of actions that you took and screen shots?

     

    The third change is the course combo box.  It is slightly different, hopefully a little better looking.  It should work better in pulling courses that you haven't used in a while.

     

    As always, if you see anything strange, please report it in the tech support forum.

     

    eric :-)


    A Dance with Monkeys

      Spectacular stuff!!
        Great job, Eric!!!  10,000 gold stars to you!

        Leslie
        Living and Running Behind the Redwood Curtain
        -------------

        2014: May - MDW 70-Miles; July - Mt. Hood 50


        "The farther you go outside, the farther you go inside." (Unknown)
        Ultrarunnerpodcast

        Trail Runner Nation

        Fatozzig's Place

         

          Hey Eric,

           

          One interesting bug with the editor is when you copy and paste from a website.  For example, if I type '5km to miles' into Google and paste the results here, it looks fine in the editor window:

           

          5 kilometers = 3.10685596 miles

           

          but when I post the message I just see html tags.


            I love the changes - truely professional in appearence and easy to use/read!  Keep up the good work.  Damm I'm going to have to donate soon.....  Again thanks Eric for putting together a great tool for us to use.
              Hey Eric,

               

              One interesting bug with the editor is when you copy and paste from a website.  For example, if I type '5km to miles' into Google and paste the results here, it looks fine in the editor window:

               

               

               

              but when I post the message I just see html tags.


               

              LuckyLindy,

              The editor is working correctly in this case.  However, the h1, h2... tags are not permitted by the RA code so they're being displayed as text instead.  I'll evaluate the need  for these tags at a later time.

               

              eric :-)

                 

                LuckyLindy,

                The editor is working correctly in this case.  However, the h1, h2... tags are not permitted by the RA code so they're being displayed as text instead.  I'll evaluate the need  for these tags at a later time.

                 

                eric :-)

                I ran into the same issue as her.  Copy/pasting text off other webpages also copies style into the WYSIWYG editor.  You can't see the tags in the editor, even if you try to modify it.  Only until you posted your message can you see the <h1> tags. I had to save the text into a .txt file before the embedded tags were removed.


                Lush Extraordinaire

                  Fantastic.  Thank you for all the work you put into this site, Eric.  You are awesome.

                  5k - 23:30

                  10k - 49:00

                  Half - 1:48:34

                  Full - 4:01:28

                   

                  Shut the eff up and run.

                    Love the private message function - thanks Eric!!


                    Prince of Fatness

                      Stupid question on the private messaging .....

                       

                      How do you address a PM if you don't click the envelope from the forums.  Say I go into messages and click New.  Do I just type the user name there?  What if the name has imbedded spaces?  If I try to send to a user that does not exist will I get an error?

                      Semi-retired.

                        Yes, you just type in the name, space and all.  When you click send, the server will check for the recipients and you will get an error if the name doesn't exist.


                        Prince of Fatness

                          Great.  Thanks Eric.

                          Semi-retired.