1

Google Maps, measure route issue (Read 81 times)

highonrunning


    RA Google Maps issue

     

    I couldn't figure out how to upload and attach an image, so i added it from my Drive.

     

    When I go to use the measure route feature in conjunction with Google Maps the map comes up blank and the following text.

     

    "This page didn't load Google Maps Correctly. See the JavaScript console for technical Details."

     

    Thank you for your help, looking forward to using this feature again soon.

     

    Love RunningAhead, Longtime user!

     

    - Using ChromeVersion 83.0.4103.106 - Up to date

    - Windows 10, PRO 1909 - 64-bit operating system

     

    LedLincoln


    not bad for mile 25

      Just checked, and it's working for me on Chrome.

      highonrunning


        Works for me on my phone using chrome. So maybe it's my laptop and I can update JavaScript somehow

         

        Just checked, and it's working for me on Chrome.

         

        Traindude


          Had same issue on June 20th. Blank with error mentioned in OP. Tried Mozilla and Chrome, same issue on both.

          Tried again 10 mins later and it worked..

            i'm getting an error as well. i'm on chrome. wonder if it is related to an ad blocker?

            https://www.instagram.com/tfilarski/

            highonrunning


              Still getting same error message on computer.

               

              rickhull


                Error message here, too. the error in the JS console seems to indicate that the API is out of date and that RA needs to update their API key.

                 

                <code>RefererNotAllowedMapError</code> Error

                The current URL loading the Maps JavaScript API has not been added to the list of allowed referrers. Please check the referrer settings of your API key in the Google Cloud Platform Console.

                LedLincoln


                not bad for mile 25

                  Hmm, checked again, and it's still working for me on Chrome (Chromebook).


                  an amazing likeness

                    Error message here, too. the error in the JS console seems to indicate that the API is out of date and that RA needs to update their API key.

                     

                      Error

                    The current URL loading the Maps JavaScript API has not been added to the list of allowed referrers. Please check the referrer settings of your API key in the Google Cloud Platform Console.

                     

                    Anyone tried Ctrl-F5 to refresh the object cache in your browser while on the Measure Route page? This sounds like dirty cache of old components.

                    Acceptable at a dance, invaluable in a shipwreck.

                    rickhull


                      Yep. No luck. F5, Ctrl-F5, and went in and purged everything (cache, cookies, hosted app data, etc.) manually. Still the same error. For me, at least, it's also happening in Chrome, Firefox, and Edge, so I don't think it's related to a plug-in, browser version, or broken update.


                      an amazing likeness

                        Yep. No luck. F5, Ctrl-F5, and went in and purged everything (cache, cookies, hosted app data, etc.) manually. Still the same error. For me, at least, it's also happening in Chrome, Firefox, and Edge, so I don't think it's related to a plug-in, browser version, or broken update.

                         

                        I can't make it happen, just mapped a few routers using a couple of the map provider options...so couple questions from curiosity...


                        What happens if you change the map provider to OSM (Open Street Map) -- or do you not even get the pick list to change the map provider?

                         

                        Are the steps (click path) to get to the error as simple as click Resources > Measure Route and then boom you're dead?

                        Acceptable at a dance, invaluable in a shipwreck.

                        rickhull


                           

                          I can't make it happen, just mapped a few routers using a couple of the map provider options...so couple questions from curiosity...


                          What happens if you change the map provider to OSM (Open Street Map) -- or do you not even get the pick list to change the map provider?

                           

                          Are the steps (click path) to get to the error as simple as click Resources > Measure Route and then boom you're dead?

                           

                          Hmmm...I don't see any pick-list to change providers, but I've never noticed a provider option, so maybe I'm just overlooking it? The map fails in the same way when I go to Measure Route or New Course from the training log. Each time there is a brief (1/2 second?) image of the correct map, then the map area goes gray and the error message is displayed.

                           

                          Interestingly, if I go to the training log and look at an existing run, I can view the map there just fine. Those existing maps are being rendered with OSM, so I think that's the difference. If I could swap the measure and new course tools to use OSM, I'd be good to go.


                          an amazing likeness

                             

                            Hmmm...I don't see any pick-list to change providers, but I've never noticed a provider option, so maybe I'm just overlooking it?

                            ...

                             

                            You're not missing it, the error rendering the map frame likely means you aren't getting the pick list rendered because the map provider pick list is in that map window of the page, like it is on the map of a workout.

                             

                            The measure route functions still default to Google rather than OSM used in the workouts maps, thus the difference in behavior.

                             

                            My **guess** is that those having the problem may be developers who have a personal google settings causing the API restriction. My thought being that were it a web server config error on just one of the web servers...there's no way the load balancer would not have more people landing on that specific web server. It would be randomly happening to many people in that case.

                            Acceptable at a dance, invaluable in a shipwreck.

                            rickhull


                              Milktruck - Thank you for all your help tracking this down. It's been fun to troubleshoot this a bit (that's not weird, right?).

                               

                              Separate from this thread, I also reached out to Eric to let him know about the problem. He wrote back last night after looking at my logs and was able to solve the problem. It wasn't related to browser settings or developer settings or anything like that. Instead, it was an outdated link to the site:

                              My shortcut to RA has always been https://runningahead.com/logs/UUID.

                               

                              That link gets me into RA just fine, but the Google mapping features fail.

                              Eric said I was using the wrong link, and needed to add the leading Ws. What do you know, https://www.runningahead.com/logs/UUID works perfectly.

                               

                              I'm not a web guy, so I had always thought that the www prefix was assumed if not entered and that www.sitename.com resolved to exactly the same location as sitename.com, but apparently that is not the case. You learn something new every day.

                               

                              Thank you Eric and Milktruck, and I hope this solution solves the problems for others on the thread, too.

                              rick.

                              LedLincoln


                              not bad for mile 25

                                Interesting. Sure enough, I see the error you were seeing when I take www off the url.

                                1