data won't upload - iMac version 10.7 (Read 899 times)


    I've recently bought a new iMac.  It has the new Lion software version 10.7.  All my old stats were successfully transferred, but I've not been able to upload any new data from Garmin to the computer.  Message says error communicating with device.  I've tried with both Safari and Firefox and get the same message.


    Hope you can help me.

    Thank you.


      I believe there is a new version of Garmin Communicator that you need to download.  Try that first

      2016 Goals

      2000 miles

      Get ready for my 2nd Boston Marathon

      No race goals, just stay healthy and work on flexibility and strength. 


        Go to http://www8.garmin.com/products/communicator/test/ and see if it can detect your GPS.  Let me know of the result and we can go from there.


          Yes, it worked!  Thank you so much.  I talked to Garmin earlier and they couldn't help me.  You're the best!



          12 Monkeys

            Garmin's test site gives me this:


            Garmin Communicator Plugin Test Page

            Communicator Plugin is properly installed and up to date, version

            Garmin GPS device is detected and communicating properly:

            Forerunner305 (Unit ID 3600981275)




            RunningAhead GOS upload is giving me this:


            You need to install the Garmin Communicator Plugin before you can use your Forerunner with RunningAHEAD.


            Seaching for GarminNetscapePlugin

            found GarminNetscapePlugin

            Plugin version:

            Status: Unable to unlock Garmin Communicator Plugin

            12 Monkeys

              That was the Mozilla / Camino Error.


              On Safari, I get this:


              There was an error communicating with your device. Please make sure your device is plugged in and turned on. If errors continue to occur, you may need to restart your device.

              Most of the time, this error can be fixed by first disconnecting the GPS from the computer, then holding onto the Mode and Reset buttons on the GPS for several seconds.

              â–¼Status: Ready
              Seaching for GarminNetscapePlugin
              found GarminNetscapePlugin
              Plugin version:
              Unlocked plugin
              Status: Detecting GPS...
              plugin.finishFindDevices() completed
              device 0 (Forerunner305 (Unit ID 3600981275)): firmware="290", data type="tcx"

              12 Monkeys

                The Garmin Connect website was able to upload. Smile