Unable to unlock Garmin Comm Plugin (Read 812 times)


    So, I tried to upload my run data from Forerunner305 to runningahead but nothing went smoothly as ever before.

    I pluged in the craddle to my PC, put the unit on it and run runningahead, but the message was that the app is not able to unlock Garmnin Communicator Plugin and I have to makse sure I have latest version of plugin installed. So I updated my plugin and started all over again, none of results changed, though.

    Could you help me fith this bug / feature? I really hate it not to be able to track my trainings on runningahead.com.


    Best regards,




      I am guessing that you are accessing http://runningahead.com instead of http://www.runningahead.com.  Garmin Communicator requires a license key to work and it is url specific.  I made some changes to automatically redirect your browser to the correct url so you should be able to import your GPS data again.


        Thanks for quick reaction, Eric! Well, now we have as much of improvement as I don't see the "Unable..." message. Now the app can't find connected GPS device despite the fact that Forerunner is plugged in properly and everything seems to be ok. The searching procedure (whirling counter) can last for over 10 minutes which is enough for me to give up. Can you tell me what's going on? Am I doing something not as I'm supposed to? Thanks in advance. Best regards, Konrad

        an amazing likeness



          First it is good to check that the Garmin software is all working by accessing the Garmin Communicator Test web page.


          If there's any problems, then you'll need to fix the Garmin software on your PC.  Usually a quick uninstall and re-install will do it.


          If that all checks out as working, then another thing to try is to use a different USB port on your PC / laptop for connecting the Garmin cradle.  Some times the change in usb address will make the Garmin Communicator start working.

          I've done my best to live the right way. I get up every morning and go to work each day. (for now)


            Gentlemen, I still get nothing, despite the actions taken described by MilkTruck above. I'm 100% sure the USB slots are ok, the unit is being read alright (test page confirms that, as well as Garmin soft on my PC), reinstallation of soft on both PC and the unit took place.. I'm getting frustrated... Best regards, Konrad


              Go to the GPS import page and try to import again.  After you deemed that the import has failed, click the little black triangle on the importer's status bar, which will expand.  In the expanded text box, type a brief message to me and click the Send button.  It'll provide the information I need to troubleshoot the problem.

                I'm 100% sure the USB slots are ok,

                FWIW, some of my USB slots don't work for FR305 uploads to RA or Garmin Training Center.  They do work if I use a slot directly off the motherboard, as opposed to one in a peripheral (card reader or monitor).  It was a pain to check, as my keyboard and mouse use the only two USB slots in my laptop.  But it made a difference!


                Just something to try.

                "I want you to pray as if everything depends on it, but I want you to prepare yourself as if everything depends on you."

                -- Dick LeBeau