Bug?: Intervals missing from xml export (Read 699 times)


    Hi All, Have any of you been able to successfully export intervals using XML? I've tried both export methods, csv and xml. It looks like my CSV export worked fine and contained the 2 intervals of my run, while the xml did not include it. CSV is nice for quickly importing into Excel and perform some analysis, however, I'd rather rely on xml as a easier to manipulate format for backups... Thanks, Guy
    Mile Collector

    Abs of Flabs

      Hi Guy, In the XML format, the intervals are embedded within each workout. Search for the < intervals="" /> tag and you'll see that they're there.

        Hi Mile Collector, It really looks like the intervals are missing for me... Here is my current output for both exports (I only have one run logged and this run has 2 intervals): CSV: log.txt: Date TimeOfDay Type SubType Distance DistanceUnit Duration Weight WeightUnit RestHR AvgHR MaxHR Sleep Calories Quality Effort Weather Temperature TempUnit Notes Course City State CourseSurface CourseNotes ShoeMake ShoeModel Size System ShoeSerial ShoePrice OverallPlace FieldSize GroupMinAge GroupMaxAge GroupPlace GroupSize GenderPlace GenderSize 2007-07-31 7:00 AM Run Easy 1.1 Kilometer 0:16:32 203.5 lb Sunny 20 C Sunny. Tried to go slowly and have low heartbeat while running. Home 1.1k loop Saint-Lazare QC Asphalt Brooks Unknown intervals.txt: Date Name WorkoutID Order Type Distance Unit Duration AvgHR MaxHR Notes 2007-07-31 Neighbourhood 1.1k loop 1 1 Interval 1.1 Kilometer 0:8:23 153 2007-07-31 Neighbourhood 1.1k loop 1 2 Interval 1.1 Kilometer 0:8:08 164 XML: log.xml: <runningaheadlog><metadata><version>2.0</version> </metadata> <coursecollection><course><id>9b13a9d454ee46299de1e15c3e4f4dbd</id> <name>Home 1.1k loop</name> <city>Saint-Lazare</city> <state>QC</state> <surface>Asphalt</surface> </course> <course><id>73832fc0bd1949b9ba4e8511f336e36a</id> <name>Random Route</name> <surface> </course> </coursecollection> <equipmentcollection><shoe><id>bed775caa4e7404f8dd1e8978b1dc2c6</id> <make>Brooks</make> <model>Unknown</model> </shoe> </equipmentcollection> <eventcollection> <run><id>1d514cd657804b7a986b287a9dcaae5d</id> <date>2007-07-31</date> <time>07:00:00</time> <type>Easy</type> <notes>Sunny. Tried to go slowly and have low heartbeat while running.</notes> <weight>203.5</weight> <weightunit>Pound</weightunit> <courseid>9b13a9d454ee46299de1e15c3e4f4dbd</courseid> <coursename>Home 1.1k loop</coursename> <distance>1.1</distance> <distanceunit>Kilometer</distanceunit> <duration>16:32</duration> <weather><condition>Sunny</condition> <temperature>20</temperature> <temperatureunit>C</temperatureunit> </weather> </run> </eventcollection> <intervalcollection></runningaheadlog> Looks like the problem could be on the last line..."<intervalcollection>"???
          Hrm... that's interesting. I got the same as you when I exported your log. At least it's reproduceable. I'll look into it.

            Hi Eric, Reproducible...That is one good way to look at it ! Guy :-)
              Hi Guy, I found, fixed, and uploaded it to the site. There was a "one-off" problem with the interval sets, meaning the number of interval sets in the xml will always be one less than the total. Since you only had one at the time, none were included. eric Smile