'An unknown error occurred while validating intervals' (Read 486 times)




    I am coming across an error when trying to save an imported session.


    To reproduce it, I go into the workout in 'imported workouts', change the conditions to 'sunny/clear', temperature to 12, workout type to hill, and press save. At the top of the workout screen it says, in red, 'An unknown error occurred while validating intervals".


    This is on Firefox 15.0.1, Linux 3.5.4-1.



      Hi djmannion,

      It is possible the error was caused by the site update at around the time of your import.  Could you give it a try again?


      eric Smile


        Hi Eric,


        Tried reimporting - same error.


        Fish Tacos

          The same thing is happening to me. Whenever I try to log a new run entry, this message comes up:

          Fatal Error

          An unexpected error occurred while processing your request.  If      this problem persists, please contact me.


            Same error here.  Same message twice when attempting to save workouts populated by Garmin GPS data.  I erased the intervals and the rest of the data saved.

              I am also getting the error.

              Orion Goals: 5k 18:30 10K 38:00 Marathon 3:10


                Stand by.  I found the problem.  A fix will be posted in about 15 minutes.

                  Thank You.  You are the best.

                  Orion Goals: 5k 18:30 10K 38:00 Marathon 3:10


                    Eric is on the ball as always...


                    Thanks Eric!

                      Thank You.  You are the best.



                      It should be mathematical, but it's not.

                        I've uploaded the fix.  Please let me know if it is fixed (or not).


                        Sorry about the problem.  One problem with code reuse and tight integration is one innocuous change may affect a completely different part of the code in unexpected ways.

                          I'm still getting the same error....thanks.


                            i was getting the same error, just tried and its still happening.


                              Yep, error is still there.


                                Just tried logging run, still "fatal error".