Error when trying to copy another user's training plan (Read 53 times)


    When I click the 'Copy' button, the following javascript error is reported in the console:

    Uncaught TypeError: Cannot call method 'open' of null f009b39b866d49b8b863d1cb9b7b57ca:83

    I tried this both in Chrome with lots of extension and in Safari without any. The only difference is that Safari is a bit more explicit:

    [Error] TypeError: 'null' is not an object (evaluating '$RAGet("ctl00_ctl00_ctl00_SiteContent_PageContent_TrainingLogContent_m_copyDlg").open')
    	onclick (f009b39b866d49b8b863d1cb9b7b57ca, line 83)

    Please let me know if you need more information.

      Hi sunkid,

      I am unable to reproduce the problem.  Which version of Safari and Chrome are you using?  I located the line in the code, but don't know how that error can occur.


      eric Smile


        I don't think it's my browser but rather this particular plan: http://www.runningahead.com/logs/fe749a6962184e588981ba94222bc6f0/plans/f009b39b866d49b8b863d1cb9b7b57ca


        I tried with IE and Firefox as well, to no avail. I can copy other plans just fine.

          There is a bug in the code that did not properly handle non-standard text in the notes.  I made the fix and it is being uploaded to the servers.  Please wait about 20 minutes for the change to take effect.


            Awesome! Thanks, Eric!


              Just FYI: I tried a couple more times to copy this particular plan and made sure to completely reload the site first. Unfortunately, it still doesn't seem to work. I have found another plan to copy by now, but I thought I would let you know.


              Thanks for all you do and happy 2014!!