Unable to copy training plan from another user's log (Read 119 times)


    I'm trying to share a training plan with another user without success.  The other user originally accessed my log through the private URL/password option, then I opened my log up publicly and we tried again.  In each case, nothing happens.


    - Access my log through the 'Browse User Logs' menu option.

    -Find my log, switch to the training plan view.

    -Open the plan to view, and click the "Copy" button.


    ... And nothing happens.  This was the behavior we had when we tried through the private URL/password and then with the publicly viewable option.  As we never tried this before, I'm not sure what behavior we are supposed to see but I assumed that same training plan would have appeared in the training plans view of the other user.


    THe training plan has already started.  The first date was last week.  Not sure if that makes a difference.





      Hi criself,

      This is a bug, but it's not what you think.  Your plan is private, so the Copy button should not have been visible.  When you try to copy it, the underlying code realized that the plan cannot be copied and aborted it.  I've updated the code to hide the copy button if the plan is private.


      eric Smile


        Hmmm. I'm not sure how I marked the training plan private because the private checkbox wasn't checked. I did try again: I made my log publicly available, then I toggled the private checkbox on the training plan and saved the plan.  If the checkbox is checked, he couldn't see the training plan at all when he went to my training plan page in my logs.  When I unchecked the box and resaved the plan, he could see the training plan again in my log, was able to see and click the copy button, but the copy doesn't show up in his training plans page. Is there a global setting from the training log options I've missed? Thanks again

          There is no record of the copied plan.  Did he provide a name for the plan?


            He's copying a plan from me.  I sent you a RA message off-line with some details. The name of the plan is 'Hoco NS 10k'.

              It seems I cannot  even copy my own plan.

                Hi criself,

                Sorry it took me so long to get back to you.  I've been focusing on more immediate problems.  The problem was caused by an invalid bit of JavaScript.  It is fixed so you should be able to copy again.


                eric Smile


                  Yup it works great.  Thanks!