Garmin 310XT won't upload a workout (Read 3406 times)

Loves the outdoors

    I'm hoping someone has had this problem and solved it before.  My Garmin 310xt for some reason is not uploading my run from this morning to Garmin Connect. It uploads the short workouts I've created since that run to try and force the upload, but it's still missing this morning's run.  I've also tried transferring all data and it's brought everything in except this workout. I can see it on the Garmin but I can't seem to get the workout off.  I'm using Windows XP with IE with the most current versions of the ANT drivers.


    Any ideas?

    One day I decided I wanted to become a runner, so I did.

    You'll ruin your knees!

      Can't say that you won't loose the data, but a hard reset may be the ticket.  I have done it both ways, have issues with the upload, then do a reset and lose the workout, and do the reset and find the workout still there and upload just fine.  Also, do an update on the firmware ASAP...  Once I did this and got the OS updated, can't remember the version now..., I never had another issue with missing an upload.


      Good luck!

      ""...the truth that someday, you will go for your last run. But not today—today you got to run." - Matt Crownover (after Western States)

        I ran into a similar problem yesterday with my Garmin 405CX.  I worked around it by uploading my data into Garmin Training Center.  From there, I exported the data for the run to a TCX file and them imported that file into Garmin Connect. 


        Interestingly, my run from today imported into Garmin Connect just fine.  So, I think maybe there was a problem on the Garmin end of things yesterday and not with my device.

        I intend to live forever . . . or die trying.

        Loves the outdoors

          It's happened again. I tried all sorts of things last time and again this time, but nothing it working Sad  This is very frustrating!  I can see all the data on the Garmin, but it won't upload for some reason.

          Garmin Firmware 2.60

          Windows XP

          ANT v 2.27

          After some searching around on the Garmin forums it appears to be a badFit file issue. For which there seems to be no solution other than sometimes Garmin tech support fixing the file manually for you. They are still "working" on the issue. I suspect this is something I'll just have to deal with, irritating as it is.

          Thought I'd post an update here just in case someone else has this issue.

          BadFit files are stored here:  

          CUndecidedDocuments and Settings\user\Application Data\GARMIN\Devices\Devicenumber\BadFITFiles

          One day I decided I wanted to become a runner, so I did.

            Any new information on this? I've had my 310XT for about a month now, and it has already happened to me three times! The first time the data was a little messed up in the watch too - individual laps had correct distance & time, but the overall workout showed 0 miles. The last two times both appear correct in the watch though, just don't transfer over to training center.


            I believe the issue is related to the watch automatically reseting the workout when it is turned on. I guess I'll have to experiment with making sure I reset the workout before turning off the watch.


            Any suggestions are appreciated!

            PRs: 5k - 18:34 (2010 Littleton Road Race) 10k - 41:40 (2010 Livestrong Philly) HM - 1:29:48 (2010 Hartford Half Marathon) M - 3:10:31 (2011 Big Sur International Marathon)