Unable to renew subscription? (Read 40 times)

Oh roo roooo!

    HI, Eric--yesterday I noticed that I had ads on RA.  I thought I had renewed earlier this year, but apparently not.  I used the "options--subscription plan" button to renew my subscription but am unable to move past the first page, as the "continue" button remains grayed out even tho I'm sure I have filled out all the necessary info.  I tried it again today and then tried it again on a different computer, and the result is the same.  Can you help me out?  Thanks!

      Hi honeypig,

      I'm not aware of any problems with the subscription page.  When you filled it out, did you notice any boxes with red borders?  The Continue button remains disabled until all the fields are filled in and are correct.  If that isn't the problem, could you take a screen shot of th epage so I can see what you're seeing?  Be sure to remove the credit card number and the security code first!


      eric Smile

      Oh roo roooo!

        Problem solved, Eric, thanks.  For some reason, the borders were remaining red around certain fields even after they were auto-filled.  I just entered a space behind each item, the border turned black, and I was good to go.  I appreciate the help.