1

Old workouts appear upon import from GPS (Read 526 times)

    Every time I get back from a run and try to import the data from my GPS watch (a Garmin FR 610), RA shows the workout from the day before as well as the workout recorded on that day.  I have the "Import new workouts only" box checked and I've already saved the workout from the day before, but it shows up anyway.  Not a big deal since it's easy to delete the one I've already imported and only save the one I'd like to, but I figured I'd post here in case I've been doing something wrong and it's an easy fix.

     

    Using the Garmin FR 610 with Garmin ANT Agent v2.2.0 from Safari 5.1.2 on an older Macbook.

    I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

     

     

    Future Goals: 5:30 mile • 19:30 5k • 33:30 8k • 42:00 10k • 1:15:00 10-mile • 1:40:00 half-marathon • 1000 miles

      Have edited the workout (the one that reappears) at all the day before the latest upload?

       

      Something in the file may be slightly different from the workout that RA has stored and RA import may think its a different workout all together.

       

      The pain that hurts the worse is the imagined pain. One of the most difficult arts of racing is learning to ignore the imagined pain and just live with the present pain (which is always bearable.) - Jeff

       

      2014 Goals:

       

      Stay healthy

      Enjoy life

       

        I change the course, type of run, equipment, weather, comments, etc. for each workout I import.  That's what I originally thought it might be, but it hasn't been showing any of my older activities - just the one from the day before I import.

        I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

         

         

        Future Goals: 5:30 mile • 19:30 5k • 33:30 8k • 42:00 10k • 1:15:00 10-mile • 1:40:00 half-marathon • 1000 miles

          I think that is a problem with the latest Garmin firmware update.  Other people have reported the same thing.  You'll have to wait for another Garmin fix.  That's the thing with Garmin.  Don't update your firmware unless you have a specific reason to do so.  Leave good enough alone.

            The thing is, it wasn't happening with Garmin Connect when the runs were uploaded directly via the ANT Agent.  Maybe it's a problem with the Communicator plugin?

            I ran. I ran until my muscles burned and my veins pumped battery acid. Then I ran some more.

             

             

            Future Goals: 5:30 mile • 19:30 5k • 33:30 8k • 42:00 10k • 1:15:00 10-mile • 1:40:00 half-marathon • 1000 miles


            In it for the long run..

              I also am getting the previous run with my 310 on the upload.  I just delete the old one.

              "It's not who wins the workout..."


              Loves the outdoors

                This happens to me too. I just delete the older ones. I think it started a month or so ago. I've got the 310xt, windows 7, chrome.
                One day I decided I wanted to become a runner, so I did.

                  Reviving an old thread, I was just wondering if anyone has solved this problem yet.  I just started using a FR 610 and am having the exact same issue.