Garmin Forerunner Integration completed (Read 3785 times)

    Love the GPS integration but I've had problems with the upload several times. It stops occasionally during "receiving tracks" and freezes up my browser so that I have to shut it down. This has happened to me in IE and FF. It just happened about 10 minutes ago in fact (in FF), so it wasn't solved with your recent bug fix. Also, the time of day that it uploaded wasn't DST though my garmin has the right time. Or maybe that's a problem with my garmin setup? Otherwise, when it works, it's like magic! Thank you! Sheri
    I get this same issue fairly often. I usually have to ctrl alt delete to even get IE to close and then start again. It sometimes takes 3 or 4 tries to get it to upload, but it does eventually upload. Thank you so much Eric this really is wonderful. Now I can track everything here instead of all over the place.
    Ginny 'Even if you're on the right track, you'll get run over if you just sit there' Will Rogers
      Eric, this is a really awesome feature. Thanks so much for all you do!

      Kerry

      HF #1048

      Concept2 - Marathons Rowed April & May 2013

       

       

       

       

       

      cmcompton


        Eric, I plugged my Edge 305 in today (work has kept me from updating) and -bingo - it worked wonderfully. This is just really cool. Cool You have a committed user and another donation!!! Thank you! cmc
          Hello, I use a garmin etrex with a serial connection. Is this supported or just the forerunners? I've installed the garmin communicator plug-in and when I go to the test page on garmin's web site this is what it tells me: Garmin Communicator Plugin Test Page Communicator Plugin is properly installed and up to date, version 2.6.4.0. Garmin GPS device is detected and communicating properly: eTrex (COM1) Big grin However, when I try to up load my map and workout info here on runningahead I get: Upload from GPS Upload from file Device: Not connected Import new workouts only Mark routes to be uploaded as publicly viewable Fill workouts to be uploaded with info from the last saved workout entry Connect Status: No GPS devices are connected. Angry can anyone help me with this? Thank You Bryan


          Imminent Catastrophe

            Russ, I'm creating a list of enhancements for GPS graphing. I'm considering allowing you to specify the smoothing range, as well as whether to hide the actual data so you can better see the smoothed graph.
            That would also enable us to limit the range of the y-axis. A pace chart that shows, say, 5 to 15 minutes per mile would be nicer than zero to 35. BTW Eric, why is it that Garmin Connect takes almost a minute and a couple attempts to download the data, but RA does it in about 2 seconds, first time, every time? Big grin

            "Able to function despite imminent catastrophe"

             "To obtain the air that angels breathe you must come to Tahoe"--Mark Twain

            "The most common question from potential entrants is 'I do not know if I can do this' to which I usually answer, 'that's the whole point'.--Paul Charteris, Tarawera Ultramarathon RD.

             

            √ Tahoe Rim Trail 100M 20/21 July 2013

            Boston Marathon 21 April 2014

            Tahoe Rim Trail 100M 19/20 July 2014


            IronMan ;)

              BTW Eric, why is it that Garmin Connect takes almost a minute and a couple attempts to download the data, but RA does it in about 2 seconds, first time, every time? Big grin
              Ain't this sweet? I can't push the refresh button fast enough, it's always ready Smile

              Tri-Kev Here are my favorite links:
              My new running club

              Swim 2.4 miles.
              Ride 112 miles.
              Run 26.2 miles.
              Then brag for the rest of your life.
              -Commander John Collins, Ironman Triathlon creator

                sherio, Someone else had a similar problem and he fixed it by doing a hard reset (press and hold "Mode" and "Reset" buttons for several seconds). If possible, you should download all your data to Training Center first so you won't lose any data. Please let me know if that helped. eric Smile
                Eric I am also having this problem. As of yesterday when I try to upload my data it freezes at 86% and the program freezes in IE. I tried a reboot on my Garmin 205 and it did nothing. My Garmin seems to be working fine, just can't upload the data now. Before yesterday it has worked like a charm everyday Greg
                  Eric I am also having this problem. As of yesterday when I try to upload my data it freezes at 86% and the program freezes in IE. I tried a reboot on my Garmin 205 and it did nothing. My Garmin seems to be working fine, just can't upload the data now. Before yesterday it has worked like a charm everyday Greg
                  Greg, Could you describe how you did the reboot? The Forerunner seem to get stuck at 86% a lot. I wonder why that is. At that point, the script that I wrote is waiting for the data to come back from the device. I suppose the script can check the progress less frequently. Maybe it's causing the problem but I doubt it... eric :-)
                    Greg, Could you describe how you did the reboot? The Forerunner seem to get stuck at 86% a lot. I wonder why that is. At that point, the script that I wrote is waiting for the data to come back from the device. I suppose the script can check the progress less frequently. Maybe it's causing the problem but I doubt it... eric :-)
                    Eric I am holding the mode & lap (reset) button togethr for about 10 seconds and then trying to transfer data again. It shows it connect and when I hit the upload button it begins as normal butthen justs freezes at 86%. This has happened multiple times and with 2 seperate run entries although it stopped at 87% yesterday after my run and then froze Greg
                      Eric I am holding the mode & lap (reset) button togethr for about 10 seconds and then trying to transfer data again. It shows it connect and when I hit the upload button it begins as normal butthen justs freezes at 86%. This has happened multiple times and with 2 seperate run entries although it stopped at 87% yesterday after my run and then froze Greg
                      Greg, I'm wondering if it's because I'm checking the download progress too often and the plugin choked. I reduced the progress check frequency. Maybe this will fix your problem? eric :-)
                        Greg, I'm wondering if it's because I'm checking the download progress too often and the plugin choked. I reduced the progress check frequency. Maybe this will fix your problem? eric :-)
                        Eric That took care of it!! Thanks working perfect now Greg
                          This is officially the greatest running site ever! Thanks, Eric!!! I am also another one who is happy to no longer have to use motionbased.
                            Hi Eric, So far have never had any problems with loading my Garmin 301 data onto the site. But today I went for a run, then without hitting reset I just changed to 'bike' in the settings menu of the Garmin.Therefore the data from today was stored as multisport. When I tried to upload it to my page the uploader just says that there is no data. Any ideas? Thanks as always for your hard work on this site. MKeith
                              MKeith, Could you contact me via the feedback form so I can obtain a copy of your tcx file for testing? Thanks! eric :-)
                                Just wanted to say I love. Love this feature!! Thank you eric, you are the man!! Was thinking that if you had some sort of subscriber system, sort of like flicr - like basic unpaid accounts, and loaded paid accounts - it would work well. I mean, I'd subsribe for sure. Cheers, caroline